Welcome! Sign in to access your account. New user?
SAFE MODE: ON HOME DIRECTORY SEARCH RANDOM POLL MAKE A POLL

JDK version usage

I'm interested in learning how many people are still using older JDKs, particularly those older than Java 5. I think many vendors would be interested in knowing whether they can cut the cord on JDK 1.4 and earlier. Let's see what people are using!

UPDATE: Looks like the text entry parts aren't displayed in the results - I'll post them periodically on this page.

What JDK version are you using in production?

4% (16) J2SE 1.3 or earlier (really?)
37% (146) J2SE 1.4
42% (163) J2SE 5.0 (annotations, generics, enums, and concurrency)
39% (151) Java SE 6
0% (3) Java SE 7 (I'm rocking my own build baby!)

387 voters have answered this question.

If you chose J2SE 1.3, 1.4 or earlier above, what is preventing you from upgrading?

10% (18) I don't want to upgrade - it's working fine!
8% (14) I can't upgrade - we tried it and the application didn't work.
44% (74) I can't upgrade. We're stuck (for other reasons) on a particular application server version that doesn't support a newer JDK. If so, what application server and version is keeping you there?
35% (58) I'd like to upgrade but IT/Operations/someone else won't let me as the newer JDK version is not approved/certified/blessed.
13% (23) I'd to like to upgrade but just haven't had time yet. If so, when do you think you will upgrade?
4% (8) I'd like to upgrade but there is no newer version available on my platform.

165 voters have answered this question.

Anything else you want to mention on this topic?

No graph available for this question

51 voters have answered this question.

This poll was created on 2008-07-09 02:12:17 by puredanger
Next Poll
Back to Category